Emergency Maintenance: C24 Cluster - Singapore Data Center

Incident Report for Pressidium® Cloud Status

Resolved

The emergency maintenance has been completed. If you are still experiencing issues, please contact our Support Team for assistance.
Posted Apr 04, 2026 - 18:24 UTC

Identified

Emergency maintenance will be performed on the C24 cluster. A brief service interruption affecting uncached content is expected during this period.
Posted Apr 04, 2026 - 17:40 UTC
This incident affected: Pressidium Services (WordPress Application Servers, Database Clusters) and Pressidium Regions (OC-West (Singapore / SG)).