The C2 cluster has remained stable, and we’re confident the issue has been resolved. If you are still experiencing any problems, please don’t hesitate to contact our Support Team for further assistance.
Posted Jun 22, 2026 - 16:42 UTC
Monitoring
We have corrected the issues affecting "C2". We will continue to monitor the situation for any further problems. If you are still experiencing connectivity issues, please reach out to our Support Team for assistance.
Posted Jun 22, 2026 - 16:19 UTC
Identified
We’re experiencing a service outage with the C2 cluster. Our team is currently working to restore the service. We apologize for any inconvenience. Users of cluster C2 users may be affected.
Posted Jun 22, 2026 - 16:08 UTC
This incident affected: Pressidium Regions (EU-West (London / UK)) and Pressidium Services (WordPress Application Servers, Database Clusters, SFTP, Staging & Snapshots).