help.pressidium.com page outage

Incident Report for Pressidium® Cloud Status

Resolved

This incident has been resolved.
Posted Apr 18, 2025 - 07:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 18, 2025 - 05:52 UTC

Identified

We’re experiencing a service outage with the help.pressidium.com page. Our team is currently working to restore the website as soon as possible. We apologize for any inconvenience.
Posted Apr 18, 2025 - 05:31 UTC