Investigating issues with "Santa Clara DC"

Incident Report for Pressidium® Cloud Status

Resolved

"Santa Clara DC" infrastructure has remained stable, and we're confident this matter has been resolved. If you are still experiencing issues, please contact our Support Team for assistance.
Posted Mar 26, 2026 - 10:46 UTC

Identified

We have identified the issue affecting the "Santa Clara DC" and have implemented mitigation measures. We will continue to monitor the situation closely for any further impact.

If you are still experiencing any connectivity issues, please do not hesitate to contact our Support Team for further assistance.
Posted Mar 25, 2026 - 11:00 UTC

Investigating

We’re experiencing a service outage with "Santa Clara DC". Our team is currently working to restore the service. We apologize for any inconvenience.
Posted Mar 25, 2026 - 10:38 UTC
This incident affected: Pressidium Services (Load Balancers, Multilayer Caching, WordPress Application Servers, Database Clusters) and Pressidium Regions (US-West (Santa Clara / US)).