Our CDN service has remained stable, and we're confident this matter has been resolved. If you are still experiencing issues, please contact our Support Team for assistance.
Posted Nov 04, 2025 - 08:53 UTC
Monitoring
We have corrected the issues affecting our CDN service. We will continue to monitor the situation for any further problems. If you are still experiencing connectivity issues, please reach out to our Support Team for assistance.
Posted Nov 04, 2025 - 07:05 UTC
Identified
We’ve identified an issue with CDN usage reporting for the current month in the Dashboard. The displayed data may be inaccurate, but this does not affect CDN service or performance. Our team is working to correct the reporting issue.